TerreSculptor

HeightMap Editor Software

User Tools

Site Tools


build_notes

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

build_notes [2013/06/08 17:17]
dgreen
build_notes [2013/10/17 20:33] (current)
dgreen
Line 1: Line 1:
 =====Build Notes===== =====Build Notes=====
  
-Build notes for TerreSculptor Pro Pre-Beta builds.+Build notes for TerreSculptor Pro Alpha builds.
  
 [[build_notes_2012|2012 Builds]] \\ [[build_notes_2012|2012 Builds]] \\
 [[build_notes_2011|2011 Builds]] [[build_notes_2011|2011 Builds]]
 +
 +
 +====Build 1.0.13.290 2013-10-17====
 +
 +Expiration Date
 +
 +  * This alpha build expires on July 01 2014
 +
 +Application
 +
 +  * Re-enabled support for Windows XP SP2. \\
 +  * Wrapped Vista+ API calls in OS version test. \\
 +  * Additional work on the application Themeing. \\
 +  * Updated the Color Button control code for more defined chip border color and disabled coloring theme. \\
 +  * Numerous bug fixes and code optimizations. \\
 +  * Numerous application form performance improvements. \\
 +  * Fixed value formatting for meters to kilometers.
 +
 +Application Form Screen Scaling Support
 +
 +  * Fixed most of the screen scaling issues when changing from Normal (96DPI) to Large (120DPI). \\
 +  * Fixed About form image scaling. \\
 +  * Fixed Options form image scaling. \\
 +  * Fixed all Export forms' top information banner image and text scaling. \\
 +  * Fixed all Import forms' top information banner image and text scaling. \\
 +  * Fixed Software Update form image scaling. \\
 +  * Fixed Splash form image scaling. \\
 +  * Fixed Welcome form image scaling.
 +
 +Benchmark
 +
 +  * Updated result file save code and a few various things.
 +
 +Binary file Load/Save
 +
 +  * Added 8-bit Signed Byte file data support. \\
 +  * Numerous improvements to load and save for the following file formats: BIL, BT, FLT, HGT, RAW, TER. \\
 +  * File load (import) Conversion Type "Auto" is now properly functional for the BIL, BT, FLT, RAW file formats.
 +
 +Error Manager
 +
 +  * Improved the error manager. \\
 +  * Additional error handling in various classes. \\
 +  * Improved error handling in various classes. \\
 +  * Improved error messages in various classes.
 +
 +Expiration Date
 +
 +  * This beta build expires on July 01 2014.
 +
 +Editor
 +
 +  * Added UDK Landscape Sizes dialog to the Tools menu (previously it was only available on the New and Resample dialogs through the UDK button).
 +
 +Event Log
 +
 +  * Improved event logging code. \\
 +  * Added additional event logging. \\
 +  * All error events are now written in the Event log.
 +
 +File Access
 +
 +  * Additional event logging on various file operations.
 +
 +File Backup send to recycle bin
 +
 +  * Fixed false event log entries. \\
 +  * Fixed memory leak.
 +
 +File Import
 +
 +  * Improved accuracy of data type Conversion of Scaled for 8-bit source data.
 +
 +File Import and Export
 +
 +  * Renamed a few options for better clarity including: Optimized to Normalize 8-bit, Type Conversion to Conversion, etc.
 +
 +File Export
 +
 +  * Changed Export Type Conversion: Auto for short and ushort data types to correctly use the full auto-scale of the source Heightmap/Floatmap/Mask. \\
 +  * Improved export to 8-bit normalized.
 +
 +File Formats
 +
 +  * Added import and export support for JPG files with .jpeg file extension. \\
 +  * Added import and export support for TIF files with .tiff file extension.
 +
 +File Format Header File Viewer
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Improved error handling. \\
 +  * Filespec label text is compacted for long filespecs.
 +
 +File Format 3DS
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Added Export Swap YZ Axis option. \\
 +  * Added Export X Origin Offset and Y Origin Offset. \\
 +  * Export with ZOffset of ObjectCenter now correctly uses the Heightmap Middle value. \\
 +  * Fixed export face data format *MESH_SMOOTHING. \\
 +  * Additional event logging. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format ASE
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Added Export Swap YZ Axis option. \\
 +  * Added Export X Origin Offset and Y Origin Offset. \\
 +  * Export with ZOffset of ObjectCenter now correctly uses the Heightmap Middle value. \\
 +  * Additional event logging. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format BIL
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Additional event logging. \\
 +  * Fixed Import dialog Resolution value. \\
 +  * Changed Export dialog setting name for Type Conversion to just Conversion. \\
 +  * Changed Import dialog setting name for Type Conversion to just Conversion. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format BT
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Additional event logging. \\
 +  * Changed Export dialog setting for Type Conversion to just Conversion. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format DEM VistaPro4
 +
 +  * Added support for Small (258x258), Large (514x514), and Huge (1026x1026) VP4 DEM formats. \\
 +  * Added support for Custom user-defined heightmap dimensions (all dimensions may not be supported by VistaPro or other VistaPro compatible software). \\
 +  * Added additional file information to the Import dialog. \\
 +  * Added additional settings to the Export dialog. \\
 +  * Added additional settings to the Import dialog. \\
 +  * Fixed bugs in file save format. \\
 +  * Improved file compatibility and header content support. \\
 +  * Numerous code improvements and performance improvements. \\
 +  * Additional event logging. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format FLT
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Additional event logging. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format GIF
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Additional event logging. \\
 +  * Error message now discerns unsupported vs invalid file format. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format HGT
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format OBJ
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Export with ZOffset of ObjectCenter now correctly uses the Heightmap Middle value. \\
 +  * Status Filespec label text is compacted for long filespecs. \\
 +  * Object List ListView control columns now set by percentage of control width instead of fixed width integers.
 +
 +File Format PNG
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Improved error messages. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format PNM
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Added PBM (.pbm) P1 file format support. \\
 +  * Added PPM (.ppm) P3 file format support. \\
 +  * Added PBM (.pbm) P4 file format support. \\
 +  * Added PPM (.ppm) P6 file format support. \\
 +  * Added PAM (.pam) P7 BlackWhite file format support. \\
 +  * Added PAM (.pam) P7 GrayscaleAlpha file format support. \\
 +  * Added PAM (.pam) P7 RGBA file format support. \\
 +  * Added PFM (.pfm) PF file format support. \\
 +  * Added PFM (.pfm) Pf file format support. \\
 +  * Added PNM (.pnm) file extension support for loading/saving any subformat. \\
 +  * Improved support for differing PNM file format variations and whitespace delimiters. \\
 +  * Changed PNM ASCII formats (P1, P2, P3) to use only the basic single newline LF character for the end-of-line delimiter by default. \\
 +  * Added Conversion property on Export dialog, removed Normalize. \\
 +  * Added EOL Delimiter property on Export dialog. \\
 +  * Added Fixed Padding property on Export dialog. \\
 +  * Added Conversion property on Import dialog, removed Auto-Scale. \\
 +  * Fixed bug in P2 export not writing last altitude value. \\
 +  * Fixed PAM naming as Portable Arbitrary Map. \\
 +  * P7RGB format now retrieves grayscale color source using the option set in the Import Image Settings. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format R64
 +
 +  * *NEW* .r64 64-bit Double-Precision Floating-Point Raw format support.
 +
 +File Format RAW
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Added support for 8-bit Signed Byte Raw format. \\
 +  * Changed Export dialog setting for Type Conversion to just Conversion. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format SB
 +
 +  * *NEW* .sb 8-bit Signed Byte raw format support.
 +
 +File Format STL
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Export with ZOffset of ObjectCenter now correctly uses the Heightmap Middle value. \\
 +  * Changed STLA file format from UTF8 to ASCII. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format TER
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Numerous minor fixes. \\
 +  * Added support for Terragen heightmap altitude data scaling (BaseHeight and HeightScale properties). \\
 +  * Added import information for additional Terragen fields: Size, XPoints, YPoints, Scale XYZ, Curve radius, Curve mode, Height scale, Base height. \\
 +  * Now supports file formats with optional or missing SIZE, XPTS, and YPTS chunks. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format TGA
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Import error messages display whether the error is a file error or an unsupported TGA format. \\
 +  * Corrected export dialog file format combobox entry text to proper 24-bit "BGR" and 32-bit "BGRA" plane order. \\
 +  * Added support for reading and writing the TGA Version 2 Extension Area block. \\
 +  * Added support for displaying the TGA Version 2 Extension Area block contents when importing a TGA V2 file. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File Format TXT
 +
 +  * Numerous code improvements and performance improvements. \\
 +  * Status Filespec label text is compacted for long filespecs.
 +
 +File IO classes
 +
 +  * Numerous enhancements and improvements and performance increases to various file I/O methods. \\
 +  * Improved handling of text files such as heightmap header files.
 +
 +Image Load and Save
 +
 +  * Improved load performance of BMP GIF JPG PNG TIF. \\
 +  * Improved save performance of BMP GIF JPG PNG TIF. \\
 +  * Import and Export to Grayscale now supports 5 different grayscale conversion methods: HSI Intensity, HSL Lightness, Luminance CCIT BT.601, Luminance BT.709, HSV Value. \\
 +  * Saving a JPG format image now uses a quality of 100% (best quality) vs the previous setting of 75% quality. \\
 +  * Saving a BMP GIF JPG PNG TIF image with the data in the Alpha bitplane now saves the RGB bitplanes as white, vs the previous setting of RGB was black.
 +
 +Options dialog
 +
 +  * Modularized the form. \\
 +  * Various updates and fixes. \\
 +  * Certain options that were not being saved are now completed.
 +
 +  * Image tab: added Import option for "16-bpp RGB source". \\
 +  * Image tab: added Import option for "16-bpp ARGB source". \\
 +  * Image tab: added Export option for "16-bpp RGB source". \\
 +  * Image tab: added Export option for "16-bpp ARGB source".
 +
 +  * Image tab: changed Import caption from "8/24-bit source" to "8-bpp RGB source". \\
 +  * Image tab: changed Import caption from "32-bit source" to "8-bpp ARGB source". \\
 +  * Image tab: changed Export caption from "8/24-bit source" to "8-bpp RGB source". \\
 +  * Image tab: changed Export caption from "32-bit source" to "8-bpp ARGB source".
 +
 +  * Image tab: added option for "Grayscale method".
 +
 +  * Ruler/Units tab: added preset for CryENGINE 3.
 +
 +Settings (ini file)
 +
 +  * Renamed TypeConversion to DataTypeConversion.
 +
 +System Information
 +
 +  * Increased size of dialog.
 +  * Changed form display order so that it appears immediately and then requests the system information. \\
 +  * System information request now occurs in a background thread. \\
 +  * Added category for installed dotNET Framework information. \\
 +  * Added category for Screens desktop working area information. \\
 +  * Added category for Theme information. \\
 +  * Added category for Windows Presentation Foundation information. \\
 +  * Additional information for system Paths. \\
 +  * Additional information for system Processors. \\
 +  * GPU status values that are unsupported on a video adapter are now shown as "Unknown". \\
 +  * Improved many item descriptions.
 +
 +Terrain Renderer
 +
 +  * Changed maximum supported heightmap resolution from 4096x4096 to 65536x65536. \\
 +  * Changed LOD mode "None" to "Normal". \\
 +  * Added user-configurable Normal LOD mode for settings of 2048,3072,4096.
  
  
Line 11: Line 308:
 Expiration Date Expiration Date
  
-  * This beta build expires on July 01 2014+  * This alpha build expires on July 01 2014
  
 Environment Changes Environment Changes
build_notes.txt ยท Last modified: 2013/10/17 20:33 by dgreen