TerreSculptor

HeightMap Editor Software

User Tools

Site Tools


build_notes

Build Notes

Build notes for TerreSculptor Pro Alpha builds.

2012 Builds
2011 Builds

Build 1.0.13.290 2013-10-17

Expiration Date

  • This alpha build expires on July 01 2014

Application

  • Re-enabled support for Windows XP SP2.
  • Wrapped Vista+ API calls in OS version test.
  • Additional work on the application Themeing.
  • Updated the Color Button control code for more defined chip border color and disabled coloring theme.
  • Numerous bug fixes and code optimizations.
  • Numerous application form performance improvements.
  • Fixed value formatting for meters to kilometers.

Application Form Screen Scaling Support

  • Fixed most of the screen scaling issues when changing from Normal (96DPI) to Large (120DPI).
  • Fixed About form image scaling.
  • Fixed Options form image scaling.
  • Fixed all Export forms' top information banner image and text scaling.
  • Fixed all Import forms' top information banner image and text scaling.
  • Fixed Software Update form image scaling.
  • Fixed Splash form image scaling.
  • Fixed Welcome form image scaling.

Benchmark

  • Updated result file save code and a few various things.

Binary file Load/Save

  • Added 8-bit Signed Byte file data support.
  • Numerous improvements to load and save for the following file formats: BIL, BT, FLT, HGT, RAW, TER.
  • File load (import) Conversion Type “Auto” is now properly functional for the BIL, BT, FLT, RAW file formats.

Error Manager

  • Improved the error manager.
  • Additional error handling in various classes.
  • Improved error handling in various classes.
  • Improved error messages in various classes.

Expiration Date

  • This beta build expires on July 01 2014.

Editor

  • Added UDK Landscape Sizes dialog to the Tools menu (previously it was only available on the New and Resample dialogs through the UDK button).

Event Log

  • Improved event logging code.
  • Added additional event logging.
  • All error events are now written in the Event log.

File Access

  • Additional event logging on various file operations.

File Backup send to recycle bin

  • Fixed false event log entries.
  • Fixed memory leak.

File Import

  • Improved accuracy of data type Conversion of Scaled for 8-bit source data.

File Import and Export

  • Renamed a few options for better clarity including: Optimized to Normalize 8-bit, Type Conversion to Conversion, etc.

File Export

  • Changed Export Type Conversion: Auto for short and ushort data types to correctly use the full auto-scale of the source Heightmap/Floatmap/Mask.
  • Improved export to 8-bit normalized.

File Formats

  • Added import and export support for JPG files with .jpeg file extension.
  • Added import and export support for TIF files with .tiff file extension.

File Format Header File Viewer

  • Numerous code improvements and performance improvements.
  • Improved error handling.
  • Filespec label text is compacted for long filespecs.

File Format 3DS

  • Numerous code improvements and performance improvements.
  • Added Export Swap YZ Axis option.
  • Added Export X Origin Offset and Y Origin Offset.
  • Export with ZOffset of ObjectCenter now correctly uses the Heightmap Middle value.
  • Fixed export face data format *MESH_SMOOTHING.
  • Additional event logging.
  • Status Filespec label text is compacted for long filespecs.

File Format ASE

  • Numerous code improvements and performance improvements.
  • Added Export Swap YZ Axis option.
  • Added Export X Origin Offset and Y Origin Offset.
  • Export with ZOffset of ObjectCenter now correctly uses the Heightmap Middle value.
  • Additional event logging.
  • Status Filespec label text is compacted for long filespecs.

File Format BIL

  • Numerous code improvements and performance improvements.
  • Additional event logging.
  • Fixed Import dialog Resolution value.
  • Changed Export dialog setting name for Type Conversion to just Conversion.
  • Changed Import dialog setting name for Type Conversion to just Conversion.
  • Status Filespec label text is compacted for long filespecs.

File Format BT

  • Numerous code improvements and performance improvements.
  • Additional event logging.
  • Changed Export dialog setting for Type Conversion to just Conversion.
  • Status Filespec label text is compacted for long filespecs.

File Format DEM VistaPro4

  • Added support for Small (258×258), Large (514×514), and Huge (1026×1026) VP4 DEM formats.
  • Added support for Custom user-defined heightmap dimensions (all dimensions may not be supported by VistaPro or other VistaPro compatible software).
  • Added additional file information to the Import dialog.
  • Added additional settings to the Export dialog.
  • Added additional settings to the Import dialog.
  • Fixed bugs in file save format.
  • Improved file compatibility and header content support.
  • Numerous code improvements and performance improvements.
  • Additional event logging.
  • Status Filespec label text is compacted for long filespecs.

File Format FLT

  • Numerous code improvements and performance improvements.
  • Additional event logging.
  • Status Filespec label text is compacted for long filespecs.

File Format GIF

  • Numerous code improvements and performance improvements.
  • Additional event logging.
  • Error message now discerns unsupported vs invalid file format.
  • Status Filespec label text is compacted for long filespecs.

File Format HGT

  • Numerous code improvements and performance improvements.
  • Status Filespec label text is compacted for long filespecs.

File Format OBJ

  • Numerous code improvements and performance improvements.
  • Export with ZOffset of ObjectCenter now correctly uses the Heightmap Middle value.
  • Status Filespec label text is compacted for long filespecs.
  • Object List ListView control columns now set by percentage of control width instead of fixed width integers.

File Format PNG

  • Numerous code improvements and performance improvements.
  • Improved error messages.
  • Status Filespec label text is compacted for long filespecs.

File Format PNM

  • Numerous code improvements and performance improvements.
  • Added PBM (.pbm) P1 file format support.
  • Added PPM (.ppm) P3 file format support.
  • Added PBM (.pbm) P4 file format support.
  • Added PPM (.ppm) P6 file format support.
  • Added PAM (.pam) P7 BlackWhite file format support.
  • Added PAM (.pam) P7 GrayscaleAlpha file format support.
  • Added PAM (.pam) P7 RGBA file format support.
  • Added PFM (.pfm) PF file format support.
  • Added PFM (.pfm) Pf file format support.
  • Added PNM (.pnm) file extension support for loading/saving any subformat.
  • Improved support for differing PNM file format variations and whitespace delimiters.
  • Changed PNM ASCII formats (P1, P2, P3) to use only the basic single newline LF character for the end-of-line delimiter by default.
  • Added Conversion property on Export dialog, removed Normalize.
  • Added EOL Delimiter property on Export dialog.
  • Added Fixed Padding property on Export dialog.
  • Added Conversion property on Import dialog, removed Auto-Scale.
  • Fixed bug in P2 export not writing last altitude value.
  • Fixed PAM naming as Portable Arbitrary Map.
  • P7RGB format now retrieves grayscale color source using the option set in the Import Image Settings.
  • Status Filespec label text is compacted for long filespecs.

File Format R64

  • *NEW* .r64 64-bit Double-Precision Floating-Point Raw format support.

File Format RAW

  • Numerous code improvements and performance improvements.
  • Added support for 8-bit Signed Byte Raw format.
  • Changed Export dialog setting for Type Conversion to just Conversion.
  • Status Filespec label text is compacted for long filespecs.

File Format SB

  • *NEW* .sb 8-bit Signed Byte raw format support.

File Format STL

  • Numerous code improvements and performance improvements.
  • Export with ZOffset of ObjectCenter now correctly uses the Heightmap Middle value.
  • Changed STLA file format from UTF8 to ASCII.
  • Status Filespec label text is compacted for long filespecs.

File Format TER

  • Numerous code improvements and performance improvements.
  • Numerous minor fixes.
  • Added support for Terragen heightmap altitude data scaling (BaseHeight and HeightScale properties).
  • Added import information for additional Terragen fields: Size, XPoints, YPoints, Scale XYZ, Curve radius, Curve mode, Height scale, Base height.
  • Now supports file formats with optional or missing SIZE, XPTS, and YPTS chunks.
  • Status Filespec label text is compacted for long filespecs.

File Format TGA

  • Numerous code improvements and performance improvements.
  • Import error messages display whether the error is a file error or an unsupported TGA format.
  • Corrected export dialog file format combobox entry text to proper 24-bit “BGR” and 32-bit “BGRA” plane order.
  • Added support for reading and writing the TGA Version 2 Extension Area block.
  • Added support for displaying the TGA Version 2 Extension Area block contents when importing a TGA V2 file.
  • Status Filespec label text is compacted for long filespecs.

File Format TXT

  • Numerous code improvements and performance improvements.
  • Status Filespec label text is compacted for long filespecs.

File IO classes

  • Numerous enhancements and improvements and performance increases to various file I/O methods.
  • Improved handling of text files such as heightmap header files.

Image Load and Save

  • Improved load performance of BMP GIF JPG PNG TIF.
  • Improved save performance of BMP GIF JPG PNG TIF.
  • Import and Export to Grayscale now supports 5 different grayscale conversion methods: HSI Intensity, HSL Lightness, Luminance CCIT BT.601, Luminance BT.709, HSV Value.
  • Saving a JPG format image now uses a quality of 100% (best quality) vs the previous setting of 75% quality.
  • Saving a BMP GIF JPG PNG TIF image with the data in the Alpha bitplane now saves the RGB bitplanes as white, vs the previous setting of RGB was black.

Options dialog

  • Modularized the form.
  • Various updates and fixes.
  • Certain options that were not being saved are now completed.
  • Image tab: added Import option for “16-bpp RGB source”.
  • Image tab: added Import option for “16-bpp ARGB source”.
  • Image tab: added Export option for “16-bpp RGB source”.
  • Image tab: added Export option for “16-bpp ARGB source”.
  • Image tab: changed Import caption from “8/24-bit source” to “8-bpp RGB source”.
  • Image tab: changed Import caption from “32-bit source” to “8-bpp ARGB source”.
  • Image tab: changed Export caption from “8/24-bit source” to “8-bpp RGB source”.
  • Image tab: changed Export caption from “32-bit source” to “8-bpp ARGB source”.
  • Image tab: added option for “Grayscale method”.
  • Ruler/Units tab: added preset for CryENGINE 3.

Settings (ini file)

  • Renamed TypeConversion to DataTypeConversion.

System Information

  • Increased size of dialog.
  • Changed form display order so that it appears immediately and then requests the system information.
  • System information request now occurs in a background thread.
  • Added category for installed dotNET Framework information.
  • Added category for Screens desktop working area information.
  • Added category for Theme information.
  • Added category for Windows Presentation Foundation information.
  • Additional information for system Paths.
  • Additional information for system Processors.
  • GPU status values that are unsupported on a video adapter are now shown as “Unknown”.
  • Improved many item descriptions.

Terrain Renderer

  • Changed maximum supported heightmap resolution from 4096×4096 to 65536×65536.
  • Changed LOD mode “None” to “Normal”.
  • Added user-configurable Normal LOD mode for settings of 2048,3072,4096.

Build 1.0.13.159 2013-06-08

Expiration Date

  • This alpha build expires on July 01 2014

Environment Changes

  • The software now requires .NET 3.5 (previous builds used .NET 3.0).
  • Support for Windows XP has been discontinued as the code and UI have been changed to utilize the Windows Vista and later UI elements.

Bug Fixes and Code Fixes

  • Fixed crash on [Enter] (Accept Button) after changing numeric control value without tabbing out first for modifiers: Altitude, Bias/Gain/Level, Clamp, Displace, Exponent, FillRegion, Filter, FloodLevel, Luminance, Offset, Pixelate, Size, Smooth.
  • Partial fix for crash on heightmaps that are a power of 255. Final complete fix is still under development.

New features

  • User Interface uses Windows Vista/7/8 'Segoe UI' font for consistent font display through the application.
  • New FileTextBox Control. This custom control is used for managing file specifications hinted as only the file name when not focused.

General changes

  • Significant updates to code for devices and generators.
  • Significant updates to code for 8-bit mask, 16-bit heightmap and 32-bit floatmap.
  • Updated welcome dialog and help menu link for User Community to point to new forums url.
  • Renamed Filter modifier to Convolution modifier through the entire application.
  • Split the Floatmap, Heightmap and Mask objects' DataStatistics methods into DataProperties (low, middle, high) and DataStatistics (mean, median, mode).
  • Changed the default statistics for Floatmap, Heightmap and Mask objects' to DataProperties only, reducing the post-update execution time by more than 50% faster.
  • Updates to the Statistics dialog and values.

About form

  • Updated form content, controls, and code.

Options form

  • Disabled currently incomplete options.

Editor form

  • Added the beta expire date to the titlebar.
  • Statusbar Mid label moved to between Min and Max.
  • Statusbar Mid label now shows proper middle altitude value with decimal.
  • Moved Software Update check into a background thread. Prevents foreground hitching if the internet server response is delayed.
  • Returning from an ImmediateMode Generator dialog now properly tracks the toolbar Colorset item and button.

Editor form Function Tab area

  • Changed code for all tab contents into individual modules.
  • Re-ordered tabs.
  • Fog tab: The Density, Start, End controls now enable/disable depending on Fog Mode for better clarity as to their functionality.
  • Grid tab: Split into individual modules.
  • Layout tab: Renamed Designer tab to Layout.
  • Layout tab: Encompasses the Designer module and Planner module.
  • Lights tab: Split into individual modules.
  • Lights tab: Toolbar buttons for Load, Save, Default now apply only to each individual module of Ambient, Directional, User.
  • Lights tab: Initial module for User Lights (6 user-defined omni or spot lights).
  • Lights tab Directional Light: Increased the size of the Angle and Direction controls.
  • Lights tab Directional Light: New Ambient, Diffuse, Specular Color settings.
  • Terrain tab: Renamed World tab to Terrain.
  • Terrain tab: New Terrain Colorset module under development.
  • Terrain tab: New Terrain Layers module under development.
  • Terrain tab: New Terrain Properties module under development.
  • Terrain tab: New Terrain Stack module under development.

Error Messages

  • Simplified plain english error messages are displayed to the user, and the full error message is written to the Event Log.

EventLog

  • More log events added.
  • EventLog Viewer form now prevents resizing below the minimum form size dimensions.
  • EventLog Viewer form now resizes the event log list column contents to the form size.

Heightmap Converter form

  • Statusbar Mid label moved to between Min and Max.
  • Statusbar Mid label now shows proper middle altitude with decimal.

Altitude Modifier

  • Deleted Middle slider and numeric controls, they were superfluous and gave incorrect impression of ability to change low-mid-high relationship.
  • Changed 'Bottom Center' for integer type heightmaps so that the heightmap is adjusted to the 0 to 32767 range of the 16-bits (vs 0 to 32768 range). Top Center is still 32768 to 65535.

Bias/Gain/Level Modifier

  • Numerous fixes: Bias and Level controls, overall functionality.

Fill Region Modifier

  • Changed order of FillStyles.
  • Added 'Middle' FillStyles value.
  • Changed Median FillStyles to proper statistical median and changed description to midpoint.

Flatten Edges Modifier

  • Changed order of FillStyles.
  • Added 'Middle' FillStyles value.
  • Changed Median FillStyles to proper statistical median and changed description to midpoint.

New Gaussian Blur Modifier

  • New modifier for smooth blurring heightmaps.

Offset Modifier

  • Changed order of FillStyles.
  • Added 'Middle' FillStyles value.
  • Changed Median FillStyles to proper statistical median and changed description to midpoint.

Pixelate Modifier

  • Various performance optimizations.
  • Added 'Middle' FillStyles value.
  • Changed Median FillStyles to proper statistical median.

New Planetize Modifier

  • New modifier for adding planetary curvature to heightmaps.

RotateCustom Modifier

  • Changed order of FillStyles.
  • Added 'Middle' FillStyles value.
  • Changed Median FillStyles to proper statistical median and changed description to midpoint.

Smooth Modifier

  • New 'Conservative' Smooth Style algorithm.
  • New 'Middle' Smooth Style algorithm.
  • Improved 'Median' Smooth Style algorithm (now uses true statistical median).
  • New 'Edge Style' Extend or Wrap property and controls, allows for proper smoothing of tilable heightmaps.
  • New 'Passes' property and controls, faster and better smoothing is often accomplished by running multiple small size passes vs one large size pass.
  • New progress bar on edit dialog.
  • Changed available 'Sizes' range from 3×3:9×9 to 3×3:21×21.
  • All smoothing occurs in the floating-point realm for all objects (mask, heightmap, floatmap).

New Tileable Modifier

  • New modifier for creating tilable masks, heightmaps, floatmaps. Note the modifier code is not 100% complete but is fully functional.

VoidFill Modifier

  • Changed order of FillStyles.
  • Added 'Low, Middle, High' FillStyles values.
  • Changed Median FillStyles to proper statistical median and changed description to midpoint.

Software Update

  • Proper handling if the server is unreachable.
  • Improved features and status.
  • Now threaded with shorter timeout.
  • Fixes to version comparisons.

Statistics form

  • Improved statistics calculations accuracy and performance.
  • Added 'Middle' value to statistics display.
  • Add 'Normalized Deviation' and 'Normalized Histogram' graph types.
  • Added Legend to Deviation graph.

System Information

  • Improved performance (prevented property re-fetch on item selection change).
  • Moved Memory information into new 'Resources' group.
  • New 'GDI Object Count' information.
  • New 'USER Object Count' information.

Terrain

  • Extents wireframe cube color now properly follows the color specified in the Settings.

-eof-

build_notes.txt · Last modified: 2013/10/17 20:33 by dgreen

Page Tools